OASIS.PROQUEST.COM 2020-10-05 18:12:45 UTC

OASIS.PROQUEST.COM20201005181245

Service Disruption


Fixed

Good news - the issue affecting access to oasis.proquest.com has been resolved, and access has resumed.

Posted , 2020-10-05 18:26:33 UTC

Investigating

Currently, a system issue is affecting access to oasis.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-10-05 18:12:45 UTC