MYIDENTIFIERS.COM 2020-08-30 11:38:00 UTC

MYIDENTIFIERS.COM20200830113800

Performance Issues


Fixed

Good news - the issue affecting the performance of myidentifiers.com has been resolved, and the product is operating normally.

Posted , 2020-08-30 15:36:00 UTC

Identified

We've identified the issue affecting the performance of myidentifiers.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2020-08-30 15:35:00 UTC

Investigating

Currently, a system issue is affecting the performance of myidentifiers.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-08-30 11:38:00 UTC