ISBN.ORG 2020-08-21 19:31:55 UTC

ISBN.ORG20200821193155

Service Disruption


Fixed

Good news - the issue affecting access to isbn.org has been resolved, and access has resumed.

Posted , 2020-08-21 20:09:54 UTC

Investigating

Currently, a system issue is affecting access to isbn.org. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-08-21 19:31:55 UTC