LIBCENTRAL 2020-08-19 06:19:36 UTC

LIBCENTRAL20200819061936

Service Disruption


Fixed

Good news - the issue affecting access to LibCentral has been resolved, and access has resumed.

Posted , 2020-08-19 06:28:22 UTC

Investigating

Currently, a system issue is affecting access to LibCentral. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-08-19 06:19:36 UTC