SEARCH.PROQUEST.COM 2020-04-20 19:15:00 UTC

SEARCH.PROQUEST.COM20200420191500

Performance Issues


Fixed

Good news - the issue affecting the performance of some access methods on search.proquest.com has been resolved, and the product is operating normally.

Posted , 2020-04-20 23:20:00 UTC

Identified

We've identified the issue affecting the performance of some access methods on search.proquest.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2020-04-20 23:16:00 UTC

Investigating

Currently, a system issue is affecting the performance of some access methods on search.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-04-20 19:15:00 UTC