SELFPUBLISHEDAUTHOR.COM 2020-03-18 03:34:40 UTC

SELFPUBLISHEDAUTHOR.COM20200318033440

Service Disruption


Fixed

Good news - the issue affecting access to selfpublishedauthor.com has been resolved, and access has resumed.

Posted , 2020-03-18 03:48:40 UTC

Investigating

Currently, a system issue is affecting access to selfpublishedauthor.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-03-18 03:34:40 UTC