EBOOK CENTRAL20191113070707
Service Disruption
Fixed
Good news - the issue affecting access to Ebook Central has been resolved, and access has resumed.
Posted ,
In Progress
We are continuing to work on resolving the issue affecting Ebook Central. Thank you for your continued patience.
Posted ,
Identified
We've identified the issue affecting Ebook Central and expect access to resume shortly. Thank you for your continued patience.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,
Investigating
Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,