OLD LEGACY REFWORKS CR01 2025-03-09 05:14:50 UTC

OLD LEGACY REFWORKS CR0120250309051450

Service Disruption


Fixed

Good news - the issue affecting access to Old Legacy RefWorks CR01 has been resolved, and access has resumed.

Posted 25 days ago, 2025-03-09 05:44:09 UTC

Investigating

Currently, a system issue is affecting access to Old Legacy RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted 25 days ago, 2025-03-09 05:14:50 UTC