REFWORKS CR01 2025-01-14 12:07:50 UTC

REFWORKS CR0120250114120750

Service Disruption


Fixed

Good news - the issue affecting access to RefWorks CR01 has been resolved, and access has resumed.

Posted , 2025-01-14 12:17:03 UTC

Investigating

Currently, a system issue is affecting access to RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2025-01-14 12:07:50 UTC