EBOOK CENTRAL 2019-09-06 00:30:00 UTC

EBOOK CENTRAL20190906003000

Service Disruption


Fixed

Good news – the issue affecting access to Ebook Central has been resolved, and access has resumed.

Posted , 2019-09-06 01:41:00 UTC

Investigating

Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-09-06 00:30:00 UTC