STATABS.PROQUEST.COM/INTERNATIONAL 2024-02-14 19:02:00 UTC

STATABS.PROQUEST.COM/INTERNATIONAL20240214190200

Service Disruption


Fixed

Good news - the issue affecting access to statabs.proquest.com/international has been resolved, and access has resumed.

Posted , 2024-02-14 20:01:00 UTC

Identified

We've identified the issue affecting statabs.proquest.com/international and expect access to resume shortly. Thank you for your continued patience.

Posted , 2024-02-14 20:00:00 UTC

Investigating

Currently, a system issue is affecting access to statabs.proquest.com/international. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2024-02-14 19:02:00 UTC