PARLIPAPERS.PROQUEST.COM 2024-02-14 19:01:00 UTC

PARLIPAPERS.PROQUEST.COM20240214190100

Service Disruption


Fixed

Good news - the issue affecting access to parlipapers.proquest.com has been resolved, and access has resumed.

Posted , 2024-02-14 20:03:00 UTC

Identified

We've identified the issue affecting parlipapers.proquest.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2024-02-14 20:01:00 UTC

Investigating

Currently, a system issue is affecting access to parlipapers.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2024-02-14 19:01:00 UTC