NEWSPAPERSLIBRARY.PROQUEST.COM 2023-08-16 20:42:00 UTC

NEWSPAPERSLIBRARY.PROQUEST.COM20230816204200

Performance Issues


Fixed

Good news - the issue affecting the performance of newspaperslibrary.proquest.com has been resolved, and the product is operating normally.

Posted , 2023-08-16 22:16:00 UTC

Identified

We've identified the issue affecting the performance of newspaperslibrary.proquest.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2023-08-16 22:13:00 UTC

Investigating

Currently, a system issue is affecting the performance of newspaperslibrary.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2023-08-16 20:42:00 UTC