AFRICANAMERICANHERITAGE.PROQUEST.COM 2023-08-16 20:40:00 UTC

AFRICANAMERICANHERITAGE.PROQUEST.COM20230816204000

Service Disruption


No Disruption

You may have received a message that stated that africanamericanheritage.proquest.com was experiencing problems. This message was sent in error - africanamericanheritage.proquest.com is operating normally and experienced no disruption today. Please disregard it and accept our apologies for any inconvenience.

Posted , 2023-08-16 20:41:00 UTC

Investigating

Currently, a system issue is affecting access to africanamericanheritage.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2023-08-16 20:40:00 UTC