REFWORKS CR01 2023-08-01 20:00:01 UTC

REFWORKS CR0120230801200001

Service Disruption


Fixed

Good news - the issue affecting access to RefWorks CR01 has been resolved, and access has resumed.

Posted , 2023-08-02 01:31:29 UTC

Investigating

Currently, a system issue is affecting access to RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2023-08-01 20:00:01 UTC