RIALTO NA03 2023-06-13 19:57:46 UTC

RIALTO NA0320230613195746

Service Disruption


Fixed

Good news - the issue affecting access to Rialto NA03 has been resolved, and access has resumed.

Posted , 2023-06-13 21:02:33 UTC

Investigating

Currently, a system issue is affecting access to Rialto NA03. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2023-06-13 19:57:46 UTC