EBOOK CENTRAL 2019-07-27 12:13:18 UTC

EBOOK CENTRAL20190727111124

Performance Issues


Fixed

Good news - the issue affecting the performance of Bookshelf on Ebook Central has been resolved, and the product is operating normally.

Posted , 2019-07-27 12:23:15 UTC

Fixed

Good news - the issue affecting the performance of Bookshelf on Ebook Central has been resolved, and the product is operating normally.

Posted , 2019-07-27 12:22:34 UTC

Investigating

Currently, a system issue is affecting the performance of Bookshelf on Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-07-27 12:13:18 UTC