NEW REFWORKS CR0120221027132536
Service Disruption
Fixed
Good news - the issue affecting access to New RefWorks CR01 has been resolved, and access has resumed.
Posted ,
Investigating
Currently, a system issue is affecting access to New RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.
Posted ,