REFWORKS CR01 2022-10-27 12:47:38 UTC

NEW REFWORKS CR0120221027124738

Service Disruption


Fixed

Good news - the issue affecting access to New RefWorks CR01 has been resolved, and access has resumed.

Posted , 2022-10-27 13:19:14 UTC

Investigating

Currently, a system issue is affecting access to New RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-10-27 12:47:38 UTC