SEARCH.PROQUEST.COM 2019-07-02 14:08:37 UTC

SEARCH.PROQUEST.COM20190702101037

Service Disruption


Fixed

Good news - the issue affecting access to search.proquest.com has been resolved, and access has resumed.

Posted , 2019-07-02 14:20:49 UTC

Identified

We've identified the issue affecting search.proquest.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2019-07-02 14:19:14 UTC

Investigating

Currently, a system issue is affecting access to search.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-07-02 14:08:38 UTC