ISBN.ORG 2022-08-23 17:02:09 UTC

ISBN.ORG20220823170209

Service Disruption


Fixed

Good news - the issue affecting access to isbn.org has been resolved, and access has resumed.

Posted , 2022-08-23 17:23:16 UTC

Investigating

Currently, a system issue is affecting access to isbn.org. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-08-23 17:02:09 UTC