REFWORKS CR01 2022-08-21 11:24:00 UTC

NEW REFWORKS CR0120220821112400

Service Disruption


Fixed

Good news - the issue affecting access to New RefWorks CR01 has been resolved, and access has resumed.

Posted , 2022-08-21 11:45:43 UTC

Investigating

Currently, a system issue is affecting access to New RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-08-21 11:24:00 UTC