GENEALOGY USAGE PORTAL 2022-07-13 23:00:00 UTC

GENEALOGY USAGE PORTAL20220713230000

Service Disruption


Fixed

Good news - the issue affecting access to Genealogy Usage Portal has been resolved, and access has resumed.

Posted , 2022-07-14 00:15:00 UTC

Identified

We've identified the issue affecting Genealogy Usage Portal and expect access to resume shortly. Thank you for your continued patience.

Posted , 2022-07-14 00:00:00 UTC

Investigating

Currently, a system issue is affecting access to Genealogy Usage Portal. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-07-13 23:00:00 UTC