ETDADMIN.COM 2019-06-07 11:52:15 UTC

ETDADMIN.COM20190607070714

Performance Issues


Fixed

Good news - the issue affecting the performance of etdadmin.com has been resolved, and the product is operating normally.

Posted , 2019-06-07 12:26:22 UTC

Identified

We've identified the issue affecting the performance of etdadmin.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2019-06-07 12:00:21 UTC

Investigating

Currently, a system issue is affecting the performance of etdadmin.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-06-07 11:52:16 UTC