OLD LEGACY REFWORKS CR01 2022-07-01 00:49:51 UTC

LEGACY REFWORKS CR0120220701004951

Service Disruption


Fixed

Good news - the issue affecting access to Legacy RefWorks CR01 has been resolved, and access has resumed.

Posted , 2022-07-01 05:57:46 UTC

Investigating

Currently, a system issue is affecting access to Legacy RefWorks CR01. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-07-01 00:49:51 UTC