EXPLORE.PROQUEST.COM 2022-06-09 05:55:00 UTC

EXPLORE.PROQUEST.COM20220609055500

Performance Issues


Fixed

Good news - the issue affecting the performance of searching on explore.proquest.com has been resolved, and the product is operating normally.

Posted , 2022-06-09 06:52:00 UTC

Identified

We've identified the issue affecting the performance of searching on explore.proquest.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2022-06-09 06:35:00 UTC

Investigating

Currently, a system issue is affecting the performance of searching on explore.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-06-09 05:55:00 UTC