OASIS.PROQUEST.COM 2022-04-30 20:24:32 UTC

OASIS.PROQUEST.COM20220430202432

Service Disruption


Fixed

Good news - the issue affecting access to oasis.proquest.com has been resolved, and access has resumed.

Posted , 2022-04-30 20:29:35 UTC

Investigating

Currently, a system issue is affecting access to oasis.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-04-30 20:24:32 UTC