OASIS-SERVICES.PROQUEST.COM 2022-02-19 21:21:25 UTC

OASIS-SERVICES.PROQUEST.COM20220219212125

Service Disruption


Fixed

Good news - the issue affecting access to oasis-services.proquest.com has been resolved, and access has resumed.

Posted , 2022-02-19 21:26:25 UTC

Investigating

Currently, a system issue is affecting access to oasis-services.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-02-19 21:21:25 UTC