OASIS.PROQUEST.COM 2022-02-10 21:28:32 UTC

OASIS.PROQUEST.COM20220210212832

Service Disruption


Fixed

Good news - the issue affecting access to oasis.proquest.com has been resolved, and access has resumed.

Posted , 2022-02-10 21:54:58 UTC

Investigating

Currently, a system issue is affecting access to oasis.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-02-10 21:28:32 UTC