NEWSPAPERSLIBRARY.PROQUEST.COM 2022-01-07 18:28:00 UTC

NEWSPAPERSLIBRARY.PROQUEST.COM20220107182800

Service Disruption


Fixed

Good news - the issue affecting access to newspaperslibrary.proquest.com has been resolved, and access has resumed.

Posted , 2022-01-07 19:53:00 UTC

Identified

We've identified the issue affecting newspaperslibrary.proquest.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2022-01-07 19:11:00 UTC

Investigating

Currently, a system issue is affecting access to newspaperslibrary.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-01-07 18:28:00 UTC