VIDEO.ALEXANDERSTREET.COM 2022-01-07 18:45:00 UTC

VIDEO.ALEXANDERSTREET.COM20220107184500

Service Disruption


Fixed

Good news - the issue affecting access to video.alexanderstreet.com has been resolved, and access has resumed.

Posted , 2022-01-07 19:52:00 UTC

Identified

We've identified the issue affecting video.alexanderstreet.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2022-01-07 19:02:00 UTC

Investigating

Currently, a system issue is affecting access to video.alexanderstreet.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-01-07 18:45:00 UTC