PUBLISHER CENTRAL 2022-01-01 11:17:28 UTC

PUBLISHER CENTRAL20220101111728

Service Disruption


Fixed

Good news - the issue affecting access to Publisher Central has been resolved, and access has resumed.

Posted , 2022-01-01 18:56:36 UTC

Investigating

Currently, a system issue is affecting access to Publisher Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2022-01-01 11:17:28 UTC