OASIS.PROQUEST.COM 2021-12-21 18:51:33 UTC

OASIS.PROQUEST.COM20211221185133

Service Disruption


Fixed

Good news - the issue affecting access to oasis.proquest.com has been resolved, and access has resumed.

Posted , 2021-12-21 18:54:32 UTC

Investigating

Currently, a system issue is affecting access to oasis.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-12-21 18:51:33 UTC