SEARCH.PROQUEST.COM 2019-03-12 12:38:03 UTC

SEARCH.PROQUEST.COM20190312080802

Performance Issues


Fixed

Good news - the issue affecting the performance of search.proquest.com has been resolved, and the product is operating normally.

Posted , 2019-03-12 13:45:23 UTC

Identified

We've identified the issue affecting the performance of search.proquest.com and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2019-03-12 12:39:36 UTC

Investigating

Currently, a system issue is affecting the performance of search.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-03-12 12:38:03 UTC