SEARCH.ALEXANDERSTREET.COM 2019-02-27 14:00:00 UTC

SEARCH.ALEXANDERSTREET.COM20190227140000

Service Disruption


Fixed

Good news - the issue affecting access to search.proquest.com has been resolved, and access has resumed.

Posted , 2019-02-27 15:40:00 UTC

Investigating

Currently, a system issue is affecting access to search.alexanderstreet.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2019-02-27 14:00:00 UTC