EBOOK CENTRAL 2021-08-27 15:45:00 UTC

EBOOK CENTRAL20210827154500

Performance Issues


Fixed

Good news - the issue affecting the performance of Authentication and Single-Sign-On on Ebook Central has been resolved, and the product is operating normally.

Posted , 2021-08-27 16:13:00 UTC

Identified

We've identified the issue affecting the performance of Authentication and Single-Sign-On on Ebook Central and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2021-08-27 16:12:00 UTC

Investigating

Currently, a system issue is affecting the performance of Authentication and Single-Sign-On on Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-08-27 15:45:00 UTC