NEWSPAPERSLIBRARY.PROQUEST.COM 2021-08-11 14:40:00 UTC

NEWSPAPERSLIBRARY.PROQUEST.COM20210811144000

Service Disruption


Root Cause

After a detailed investigation, we’ve determined the cause of this interruption to newspaperslibrary.proquest.com. You can see more details here.

Posted , 2021-08-13 11:50:00 UTC

Fixed

Good news - the issue affecting access to newspaperslibrary.proquest.com has been resolved, and access has resumed.

Posted , 2021-08-11 22:03:00 UTC

Identified

We've identified the issue affecting newspaperslibrary.proquest.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2021-08-11 22:02:00 UTC

Investigating

Currently, a system issue is affecting access to newspaperslibrary.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-08-11 14:40:00 UTC