EBOOK CENTRAL 2021-04-01 07:46:00 UTC

EBOOK CENTRAL20210401074600

Service Disruption


Fixed

Good news - the issue affecting access to Ebook Central has been resolved, and access has resumed.

Posted , 2021-04-01 12:10:24 UTC

Investigating

Currently, a system issue is affecting access to Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-04-01 07:46:00 UTC