OASIS-SERVICES.PROQUEST.COM 2021-03-03 21:39:39 UTC

OASIS-SERVICES.PROQUEST.COM20210303213939

Service Disruption


Fixed

Good news - the issue affecting access to oasis-services.proquest.com has been resolved, and access has resumed.

Posted , 2021-03-03 21:49:10 UTC

Investigating

Currently, a system issue is affecting access to oasis-services.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-03-03 21:39:39 UTC