SELFPUBLISHEDAUTHOR.COM 2021-02-17 13:34:41 UTC

SELFPUBLISHEDAUTHOR.COM20210217133441

Service Disruption


Fixed

Good news - the issue affecting access to selfpublishedauthor.com has been resolved, and access has resumed.

Posted , 2021-02-17 15:15:44 UTC

Identified

We've identified the issue affecting selfpublishedauthor.com and expect access to resume shortly. Thank you for your continued patience.

Posted , 2021-02-17 13:49:00 UTC

Investigating

Currently, a system issue is affecting access to selfpublishedauthor.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2021-02-17 13:34:41 UTC