LIBCENTRAL 2020-11-11 07:59:34 UTC

LIBCENTRAL20201111075934

Service Disruption


No Disruption

You may have received a message that stated that LibCentral was experiencing problems. This message was sent in error - LibCentral is operating normally and experienced no disruption today. Please disregard it and accept our apologies for any inconvenience.

Posted , 2020-11-11 12:44:00 UTC

Investigating

Currently, a system issue is affecting access to LibCentral. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-11-11 07:59:34 UTC