EBOOK CENTRAL 2020-11-02 11:11:18 UTC

EBOOK CENTRAL20201102111118

Performance Issues


Root Cause

After a detailed investigation, we’ve determined the cause of this interruption to Ebook Central. You can see more details here.

Posted , 2020-11-05 19:26:00 UTC

Fixed

Good news - the issue affecting the performance of Search on Ebook Central has been resolved, and the product is operating normally.

Posted , 2020-11-02 12:51:00 UTC

Identified

We've identified the issue affecting the performance of Search on Ebook Central and expect to resolve it shortly. Thank you for your continued patience.

Posted , 2020-11-02 12:48:00 UTC

Investigating

Currently, a system issue is affecting the performance of Search on Ebook Central. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-11-02 11:11:18 UTC