OASIS-SERVICES.PROQUEST.COM 2020-10-06 07:16:38 UTC

OASIS-SERVICES.PROQUEST.COM20201006071638

Service Disruption


Fixed

Good news - the issue affecting access to oasis-services.proquest.com has been resolved, and access has resumed.

Posted , 2020-10-06 07:37:13 UTC

Investigating

Currently, a system issue is affecting access to oasis-services.proquest.com. Our engineers are working quickly to fix the issue, and we'll update you as soon as we know more.

Posted , 2020-10-06 07:16:38 UTC